Script:
Owner:
Subdir:
Blog ID: 75809171
Group ID: User ID:

Top Point Earners

 
Select Forum or Category:
Post Reply
SSL Exception
4 years ago  ::  Jun 30, 2010 - 12:43PM #1
Rahul
WebSphere Admin
Uline Inc
Posts: 3

Hi guys,


i get the following exception in the application server's systemout.log every 5 minutes


6/30/10 11:41:35:576 EDT] 00000028 SSLHandshakeE E   SSLC0008E: Unable to initialize SSL connection.  Unauthorized access was denied or security settings have expired.  Exception is javax.net.ssl.SSLException: Unrecognized SSL message, plaintext connection?
        at com.ibm.jsse2.b.a(b.java:36)
        at com.ibm.jsse2.pc.a(pc.java:292)
        at com.ibm.jsse2.pc.unwrap(pc.java:20)
        at javax.net.ssl.SSLEngine.unwrap(SSLEngine.java:17)
        at com.ibm.ws.ssl.channel.impl.SSLConnectionLink.readyInbound(SSLConnectionLink.java:531)
        at com.ibm.ws.ssl.channel.impl.SSLConnectionLink.ready(SSLConnectionLink.java:291)
        at com.ibm.ws.tcp.channel.impl.NewConnectionInitialReadCallback.sendToDiscriminators(NewConnectionInitialReadCallback.java:214)
        at com.ibm.ws.tcp.channel.impl.NewConnectionInitialReadCallback.complete(NewConnectionInitialReadCallback.java:113)
        at com.ibm.ws.tcp.channel.impl.AioReadCompletionListener.futureCompleted(AioReadCompletionListener.java:165)
        at com.ibm.io.async.AbstractAsyncFuture.invokeCallback(AbstractAsyncFuture.java:217)
        at com.ibm.io.async.AsyncChannelFuture.fireCompletionActions(AsyncChannelFuture.java:161)
        at com.ibm.io.async.AsyncFuture.completed(AsyncFuture.java:138)
        at com.ibm.io.async.ResultHandler.complete(ResultHandler.java:204)
        at com.ibm.io.async.ResultHandler.runEventProcessingLoop(ResultHandler.java:775)
        at com.ibm.io.async.ResultHandler$2.run(ResultHandler.java:905)
        at com.ibm.ws.util.ThreadPool$Worker.run(ThreadPool.java:1527)


 


i checked all the ssl configurations for any certificate expiry and everything looks good. and it is a websphere cluster with 2 application server and the version is


WAS v7.0.0.3 ND.


DMGR and 1 appserver profile on 1 server and another app server profile on 2nd box federated to DMGR and as mentioned both the servers are in cluster.


any pointers will be highly helpful.


 


thanks


Rahul.

0 (0 Ratings)
4 years ago  ::  Jul 01, 2010 - 10:46AM #2
Joseph
WebSphere Platform Technology Consultant
Consulting Ltd
Posts: 346

Sync the certificate across all nodes and see

0 (0 Ratings)
4 years ago  ::  Jul 01, 2010 - 11:20AM #3
Rahul
WebSphere Admin
Uline Inc
Posts: 3

tried that and still the same...thanks for the suggestion ...

0 (0 Ratings)
4 years ago  ::  Jul 07, 2010 - 9:57AM #4
Rahul
WebSphere Admin
Uline Inc
Posts: 3

hi guys,


i have opened up a pmr for this issue, the l2 support says that there was an unsecure connection thru a secure port and you can ignore this message as long as this exception does not harm the application. but they have also asked me to apply the latest CF 7.0.0.11.


 


thanks


Rahul

0 (0 Ratings)
    Viewing this thread :: 0 registered and 1 guest
    No registered users viewing

Connect w/ Others

Member of the Month

    • WebSphere z/OS System Administrator
      CSC